const regex = /(?<=^|\b|(?<=\W)(?=\W))\S+?(?=$|\b|(?<=\W)(?=\W))/gs;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^|\\b|(?<=\\W)(?=\\W))\\S+?(?=$|\\b|(?<=\\W)(?=\\W))', 'gs')
const str = `#include <stdio.h>
int main()
{
printf("Hello, World!");
return 0;
}
public class HelloWorld {
public static void main(String[] args) {
System.out.println("Hello, World!");
}
}
MsgBox, Hello, World!`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}