using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^---$((.)*)^---$";
string input = @"---
Created: 20.07.2023
Tags: #kleiderschrank, #golf
---
# Kleiderschrank | Golf
## Polos kurz schwarz (#polo)
2018-11 | 2 x Under Armour Herren Performance Poloshirt, Schwarz, XL
0000-00 | Nike Polos Standard FIT XL black
0000-00 | AIRBUS Bremen XL black
2018-05 | Golfino Poloshirt kurz grün
2018-05 | Golfino Poloshirt kurz türkis
2016-07 | 4 x Decathlon Polos
0000-00 | Adidas Polo XL hellgrau
0000-00 | Adidas Polo L signalrot
0000-00 | Adidas Polo L signalrot
## Polos lang
2019-04 | Golfino Poloshirt lang
## Pullover (#pullover)
0000-00 | Decathlon Fleece XL hellgrau
0000-00 | Decathlon Fleece XL blau
## Windshields (#windshields)
2019-04 | Nike Herren-Golfjacke mit Synthetikfüllung XL Schwarz
2019-04 | Golfino Thermo Jacke gesteppt schwarz 56
2017-06 | Golfino Windshield Fleece Jacke black
0000-00 | Golfino Shell dunkelbau
2017-06 | Golfino ThermoShirt 1/2 Zip blau 54
0000-00 | Golfino Jacke schwarz
## Rain Shirts (#rainshirts)
0000-00 | FootJoy Hydrolite Rainshirt XL black
2015-09 | Under Armour Herren Golf Pullover Crestable Elements 1/2 Zip, Black, XL
## Westen (#westen)
2018-05 | Golfino Mikrofaser Weste Navy
2019-04 | Golfino Weste gesteppt schwarz 56
## Zipper lang (#zipper)
2018-05 | Golfino Troyer Zip schwarz lang
2018-05 | Golfino Troyer Zip blau lang
2018-05 | Golfino Troyer Zip grün lang
2018-05 | Golfino Troyer Zip rot lang
2018-05 | Golfino Troyer Zip rot lang
## Hosen (#hosen)
0000-00 | Golfino 54 schwarz
0000-00 | Alberto chino 54 schwarz
0000-00 | Adidas blau 32/34
## Schuhe
2018-08 | FootJoy Golfschuhe Contour Casual 45 braun
2018-08 | FootJoy Golfschuhe Contour Fit 45 schwarz
2015-09 | Nike
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}