#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^---$((.)*)^---$"
Local $sString = "---" & @CRLF & _
"Created: 20.07.2023" & @CRLF & _
"Tags: #kleiderschrank, #golf" & @CRLF & _
"---" & @CRLF & _
"" & @CRLF & _
"# Kleiderschrank | Golf" & @CRLF & _
"" & @CRLF & _
"## Polos kurz schwarz (#polo)" & @CRLF & _
"2018-11 | 2 x Under Armour Herren Performance Poloshirt, Schwarz, XL" & @CRLF & _
"0000-00 | Nike Polos Standard FIT XL black" & @CRLF & _
"0000-00 | AIRBUS Bremen XL black" & @CRLF & _
"2018-05 | Golfino Poloshirt kurz grün" & @CRLF & _
"2018-05 | Golfino Poloshirt kurz türkis" & @CRLF & _
"2016-07 | 4 x Decathlon Polos" & @CRLF & _
"0000-00 | Adidas Polo XL hellgrau" & @CRLF & _
"0000-00 | Adidas Polo L signalrot" & @CRLF & _
"0000-00 | Adidas Polo L signalrot" & @CRLF & _
"" & @CRLF & _
"## Polos lang" & @CRLF & _
"2019-04 | Golfino Poloshirt lang" & @CRLF & _
"" & @CRLF & _
"## Pullover (#pullover)" & @CRLF & _
"0000-00 | Decathlon Fleece XL hellgrau" & @CRLF & _
"0000-00 | Decathlon Fleece XL blau" & @CRLF & _
"" & @CRLF & _
"## Windshields (#windshields)" & @CRLF & _
"" & @CRLF & _
"2019-04 | Nike Herren-Golfjacke mit Synthetikfüllung XL Schwarz" & @CRLF & _
"2019-04 | Golfino Thermo Jacke gesteppt schwarz 56" & @CRLF & _
"2017-06 | Golfino Windshield Fleece Jacke black" & @CRLF & _
"0000-00 | Golfino Shell dunkelbau" & @CRLF & _
"2017-06 | Golfino ThermoShirt 1/2 Zip blau 54" & @CRLF & _
"0000-00 | Golfino Jacke schwarz" & @CRLF & _
"" & @CRLF & _
"## Rain Shirts (#rainshirts)" & @CRLF & _
"" & @CRLF & _
"0000-00 | FootJoy Hydrolite Rainshirt XL black" & @CRLF & _
"2015-09 | Under Armour Herren Golf Pullover Crestable Elements 1/2 Zip, Black, XL" & @CRLF & _
"" & @CRLF & _
"## Westen (#westen)" & @CRLF & _
"" & @CRLF & _
"2018-05 | Golfino Mikrofaser Weste Navy" & @CRLF & _
"2019-04 | Golfino Weste gesteppt schwarz 56" & @CRLF & _
"" & @CRLF & _
"## Zipper lang (#zipper)" & @CRLF & _
"2018-05 | Golfino Troyer Zip schwarz lang" & @CRLF & _
"2018-05 | Golfino Troyer Zip blau lang" & @CRLF & _
"2018-05 | Golfino Troyer Zip grün lang" & @CRLF & _
"2018-05 | Golfino Troyer Zip rot lang" & @CRLF & _
"2018-05 | Golfino Troyer Zip rot lang" & @CRLF & _
"" & @CRLF & _
"## Hosen (#hosen)" & @CRLF & _
"0000-00 | Golfino 54 schwarz" & @CRLF & _
"0000-00 | Alberto chino 54 schwarz" & @CRLF & _
"0000-00 | Adidas blau 32/34" & @CRLF & _
"" & @CRLF & _
"## Schuhe" & @CRLF & _
"2018-08 | FootJoy Golfschuhe Contour Casual 45 braun" & @CRLF & _
"2018-08 | FootJoy Golfschuhe Contour Fit 45 schwarz" & @CRLF & _
"2015-09 | Nike" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")