re = / */m
str = 'This isn\'t a relevant question , is it?
Is,it correct , question?
S.?
Questionword ,anotherquestionword,?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end