$re = '/^(?!.*?[.]{2})[a-z0-9]+[a-z0-9._%\-+]*[a-z0-9]@[a-z0-9]+[a-z0-9.-]*[a-z0-9]*\.[a-z]{2,24}$/';
$str = 'Some very long company name that does not match the regex @%! gfdsa fds dfs fdsa fds fdsa fdsa fdasf dsa fdsa fdsa fdsa fdsafdsfdfdsfsdfsdfsdfdsfsdfdfds fdsafdsaf df fdfdfdsfsdfsffsd';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);