#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(?!.*?[.]{2})[a-z0-9]+[a-z0-9._%\-+]*[a-z0-9]@[a-z0-9]+[a-z0-9.-]*[a-z0-9]*\.[a-z]{2,24}$"
Local $sString = "Some very long company name that does not match the regex @%! gfdsa fds dfs fdsa fds fdsa fdsa fdasf dsa fdsa fdsa fdsa fdsafdsfdfdsfsdfsdfsdfdsfsdfdfds fdsafdsaf df fdfdfdsfsdfsffsd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")