const regex = /^(ACD|AOC|AML|AMR|AS|BDC|BDH|BDS|BDW|BFW|BOW|BRW|BWH|BWL|BWM|BWV|CAA|CAC|CAD|CAE|CAR|CAT|CDM|CDR|CFD|CHD|CKE|CO2|CS|CSS|CWR|CWS|DEW|DIS|DMW|DRS|DSW|DW|FG|FLO|FO|FPF|FWS|HC|HCS|HFL|HFO|HPS|HOS|HRG|HSO|HYD|IA|LCS|LFL|LFO|LO|LPS|LSO|MDA|MET|MPSNG|NGP|NI|NIL|OFS|OG|OWS|PA|PR|PRA|PW|QO|QW|REH|REL|RFG|SAN|SCA|SCC|SHC|SCL|SCM|SCO|SCP|SEG|SEO|SFL|SOG|SOW|SSW|SUL|SVV|SW|SWD|SWR|SWS|TFL|TRM|TRW|VNT|VPS)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(ACD|AOC|AML|AMR|AS|BDC|BDH|BDS|BDW|BFW|BOW|BRW|BWH|BWL|BWM|BWV|CAA|CAC|CAD|CAE|CAR|CAT|CDM|CDR|CFD|CHD|CKE|CO2|CS|CSS|CWR|CWS|DEW|DIS|DMW|DRS|DSW|DW|FG|FLO|FO|FPF|FWS|HC|HCS|HFL|HFO|HPS|HOS|HRG|HSO|HYD|IA|LCS|LFL|LFO|LO|LPS|LSO|MDA|MET|MPSNG|NGP|NI|NIL|OFS|OG|OWS|PA|PR|PRA|PW|QO|QW|REH|REL|RFG|SAN|SCA|SCC|SHC|SCL|SCM|SCO|SCP|SEG|SEO|SFL|SOG|SOW|SSW|SUL|SVV|SW|SWD|SWR|SWS|TFL|TRM|TRW|VNT|VPS)', 'gm')
const str = `ACD
AOC`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}