#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(ACD|AOC|AML|AMR|AS|BDC|BDH|BDS|BDW|BFW|BOW|BRW|BWH|BWL|BWM|BWV|CAA|CAC|CAD|CAE|CAR|CAT|CDM|CDR|CFD|CHD|CKE|CO2|CS|CSS|CWR|CWS|DEW|DIS|DMW|DRS|DSW|DW|FG|FLO|FO|FPF|FWS|HC|HCS|HFL|HFO|HPS|HOS|HRG|HSO|HYD|IA|LCS|LFL|LFO|LO|LPS|LSO|MDA|MET|MPSNG|NGP|NI|NIL|OFS|OG|OWS|PA|PR|PRA|PW|QO|QW|REH|REL|RFG|SAN|SCA|SCC|SHC|SCL|SCM|SCO|SCP|SEG|SEO|SFL|SOG|SOW|SSW|SUL|SVV|SW|SWD|SWR|SWS|TFL|TRM|TRW|VNT|VPS)"
Local $sString = "ACD" & @CRLF & _
"AOC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")