$re = '/^[\s]*(\ba\s+\"[^\"]*\S[^\"]*\"\s+(\(\s*[-0-9]+\s*,\s*[-0-9]+\s*\)\s*)+$|\bc\s+\".*\S.*\"\s+(\(\s*[-0-9]+\s*,\s*[-0-9]+\s*\)\s*)+$|\bg\s*$|\br\s+\".*\S.*\"\s*$)/m';
$str = ' a "dsa (1,3)" (1, 3)
g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);