$re = '/2\d{3}-(0[1-9]|1[0-2])-([0,2][1-9])/';
$str = '2014-05-22';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);