$re = '/(^(?<barCodeId>\d{2})(?<serviceType>\d{3})(?<mailerId>\d{9})(?<uniqueSequence>\d{6})(?<dpbc>.{11}))/m';
$str = '0014120556239013447647712510026
0014120556239013447747712556417
0014120556239013447847712504124
0014120556239013447947712500422
0014120556239013448047712482006
0014120556239013448147712494417
0014120556239013448247712935544';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);