const regex = /repository:\s+['"]?(?<depName>[_\-\/\w]+)['"]?,?\s+tag:\s+['"]?(?<currentValue>[_\-\.\w]+)['"]?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('repository:\\s+[\'"]?(?<depName>[_\\-\\\/\\w]+)[\'"]?,?\\s+tag:\\s+[\'"]?(?<currentValue>[_\\-\\.\\w]+)[\'"]?', 'gm')
const str = ` image: { repository: user_name-123/repo_name-123, tag: v1.23.45_amd64-cluster }
image:
repository: "user_name-123/repo_name-123"
tag: 'v1.23.45_amd64-cluster'`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}