# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<script([\s\S]*?)>([\s\S]*?)<\/script>"
test_str = ("<template>\n"
" <div :class=\"classObj\" class=\"app-wrapper\">\n"
" <div v-if=\"device==='mobile'&&sidebar.opened\" class=\"drawer-bg\" @click=\"handleClickOutside\" />\n"
" <sidebar class=\"sidebar-container\" />\n"
" <div :class=\"{hasTagsView:needTagsView}\" class=\"main-container\">\n"
" <div :class=\"{'fixed-header':fixedHeader}\">\n"
" <navbar />\n"
" <tags-view v-if=\"needTagsView\" />\n"
" </div>\n"
" <app-main />\n"
" <right-panel v-if=\"showSettings\">\n"
" <settings />\n"
" </right-panel>\n"
" </div>\n"
" </div>\n"
"</template>\n\n"
"<script>\n"
"import RightPanel from '@/components/RightPanel'\n"
"import { AppMain, Navbar, Settings, Sidebar, TagsView } from './components'\n"
"import ResizeMixin from './mixin/ResizeHandler'\n"
"import { mapState } from 'vuex'\n\n"
"export default {\n"
" name: 'Layout',\n"
" components: {\n"
" AppMain,\n"
" Navbar,\n"
" RightPanel,\n"
" Settings,\n"
" Sidebar,\n"
" TagsView\n"
" },\n"
" mixins: [ResizeMixin],\n"
" computed: {\n"
" ...mapState({\n"
" sidebar: state => state.app.sidebar,\n"
" device: state => state.app.device,\n"
" showSettings: state => state.settings.showSettings,\n"
" needTagsView: state => state.settings.tagsView,\n"
" fixedHeader: state => state.settings.fixedHeader\n"
" }),\n"
" classObj() {\n"
" return {\n"
" hideSidebar: !this.sidebar.opened,\n"
" openSidebar: this.sidebar.opened,\n"
" withoutAnimation: this.sidebar.withoutAnimation,\n"
" mobile: this.device === 'mobile'\n"
" }\n"
" }\n"
" },\n"
" methods: {\n"
" handleClickOutside() {\n"
" this.$store.dispatch('app/closeSideBar', { withoutAnimation: false })\n"
" }\n"
" }\n"
"}\n"
"</script>\n\n"
"<style lang=\"scss\" scoped>\n"
" @import \"~@/styles/mixin.scss\";\n"
" @import \"~@/styles/variables.scss\";\n\n"
" .app-wrapper {\n"
" @include clearfix;\n"
" position: relative;\n"
" height: 100%;\n"
" width: 100%;\n\n"
" &.mobile.openSidebar {\n"
" position: fixed;\n"
" top: 0;\n"
" }\n"
" }\n\n"
" .drawer-bg {\n"
" background: #000;\n"
" opacity: 0.3;\n"
" width: 100%;\n"
" top: 0;\n"
" height: 100%;\n"
" position: absolute;\n"
" z-index: 999;\n"
" }\n\n"
" .fixed-header {\n"
" position: fixed;\n"
" top: 0;\n"
" right: 0;\n"
" z-index: 9;\n"
" width: calc(100% - #{$sideBarWidth});\n"
" transition: width 0.28s;\n"
" }\n\n"
" .hideSidebar .fixed-header {\n"
" width: calc(100% - 54px)\n"
" }\n\n"
" .mobile .fixed-header {\n"
" width: 100%;\n"
" }\n"
"</style>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.