# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<Hex>(?<=.[^}{])#(?:[\dA-F]{6}|[\dA-F]{3})(?=\W[^}{]))+"
test_str = ("#BED\n"
"{\n"
" color: #FfFdF8; background-color:#aef;\n"
" font-size: 123px;\n"
" background: -webkit-linear-gradient(top, #f9f9f9, #fff);\n"
"}\n\n"
"#Cab\n"
"{\n"
" background-color: #ABC;\n"
" border: 2px dashed #fff;\n"
"} \n\n"
"#dddd\n\n"
"Valid Hex Color Codes\n"
"#FFF \n"
"#025 \n"
"#F0A1FB \n\n"
"Invalid Hex Color Codes\n"
"#fffabg\n"
"#abcf\n"
"#12365erff\n\n"
"#BED{ color: #FfFdF8; background-color:#aef; font-size: 123px;}#Cab{ background-color: #ABC; border: 2px dashed #fff;}\n")
matches = re.finditer(regex, test_str, re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.