$re = '/.*[\\\\]/';
$str = 'app\\Class1.php
app\\Class2.php
app\\spl_autoload.php
app\\testDir
app\\testDir\\test.txt
app\\anotherDir\\verydeepDirectory\\extraDeepDirectory\\secretMessage.txt
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);