package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(([0-9]{4})(-[0-9]{2}){2})`)
var str = `2022-08-22T03:02:20+0700`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}