const regex = /Retails_OB_(?<YYYY>\d{4})(?<MM>\d{2})(?<DD>\d{2}).csv/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Retails_OB_(?<YYYY>\\d{4})(?<MM>\\d{2})(?<DD>\\d{2}).csv', 'gm')
const str = `Retails OB.csv
Retails_OB_20200717.csv
Retails_OB_20200723.csv
Retails_OB_20200804.csv
Retails_OB_20200814.csv
Retails_OB_20200821.csv
Retails_OB_20200825.csv
Retails_OB_20200902.csv
Retails_OB_20200910.csv
Retails_OB_20200917.csv
Retails_OB_20200924.csv
Retails_OB_20200929.csv
Retails_OB_20201006.csv
Retails_OB_20201013.csv
Retails_OB_20201021.csv
Retails_OB_20201028.csv
Retails_OB_20201119.csv
Retails_OB_20201125.csv
Retails_OB_20201214.csv
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}