# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\|-uint32_t \(\[\d*\]\) \= (\d*) \(\dx\w+\))"
test_str = ("|-uint32_t ([0]) = 2865385407 (0xaaca4fbf)\n"
"|-uint32_t ([1]) = 2865397407 (0xaaca7e9f)\n"
"|-uint32_t ([2]) = 2865409407 (0xaacaad7f)\n"
"|-uint32_t ([3]) = 2865421407 (0xaacadc5f)\n"
"|-uint32_t ([4]) = 2865433407 (0xaacb0b3f)\n"
"|-uint32_t ([5]) = 2865445407 (0xaacb3a1f)\n"
"|-uint32_t ([6]) = 2865457407 (0xaacb68ff)\n"
"|-uint32_t ([7]) = 2865469407 (0xaacb97df)\n"
"|-uint32_t ([8]) = 2865481407 (0xaacbc6bf)\n"
"|-uint32_t ([9]) = 2865493407 (0xaacbf59f)\n"
"|-uint32_t ([10]) = 2865505407 (0xaacc247f)\n"
"|-uint32_t ([11]) = 2865517407 (0xaacc535f)\n"
"|-uint32_t ([12]) = 2865529407 (0xaacc823f)\n"
"|-uint32_t ([13]) = 2865541408 (0xaaccb120)\n"
"|-uint32_t ([14]) = 2865553408 (0xaacce000)\n"
"|-uint32_t ([15]) = 2865565408 (0xaacd0ee0)\n"
"|-uint32_t ([16]) = 2865577408 (0xaacd3dc0)\n"
"|-uint32_t ([17]) = 2865589408 (0xaacd6ca0)\n"
"|-uint32_t ([18]) = 2865601408 (0xaacd9b80)\n"
"|-uint32_t ([19]) = 2865613408 (0xaacdca60)\n"
"|-uint32_t ([20]) = 2865625408 (0xaacdf940)\n"
"|-uint32_t ([21]) = 2865637408 (0xaace2820)\n"
"|-uint32_t ([22]) = 2865649408 (0xaace5700)\n"
"|-uint32_t ([23]) = 2865661408 (0xaace85e0)\n"
"|-uint32_t ([24]) = 2865673408 (0xaaceb4c0)\n"
"|-uint32_t ([25]) = 2865685408 (0xaacee3a0)\n"
"|-uint32_t ([26]) = 2865697408 (0xaacf1280)\n"
"|-uint32_t ([27]) = 2865709408 (0xaacf4160)\n"
"|-uint32_t ([28]) = 2865721408 (0xaacf7040)\n"
"|-uint32_t ([29]) = 2865733409 (0xaacf9f21)\n"
"|-uint32_t ([30]) = 2865745409 (0xaacfce01)\n"
"|-uint32_t ([31]) = 2865757409 (0xaacffce1)\n"
"|-uint32_t ([32]) = 2865769409 (0xaad02bc1)\n"
"|-uint32_t ([33]) = 2865781409 (0xaad05aa1)\n"
"|-uint32_t ([34]) = 2865793409 (0xaad08981)\n"
"|-uint32_t ([35]) = 2865805409 (0xaad0b861)\n"
"|-uint32_t ([36]) = 2865817409 (0xaad0e741)\n"
"|-uint32_t ([37]) = 2865829409 (0xaad11621)\n"
"|-uint32_t ([38]) = 2865841409 (0xaad14501)\n"
"|-uint32_t ([39]) = 2865853409 (0xaad173e1)\n")
subst = "\\2"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.