using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"9([\s]*)(\d[\s]*){9}";
string input = @"HELLO9 40 0001 103 940 060 1148 96 20 01 47 14 940 00A011 27 9 620014 724 9 320009350 9 62 0005 368WORLD";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}