import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<suburb>(.+?)<\\/suburb>";
final String string = " <primaryAddress>\n"
+ " <addressLine>280 Flinders Mall</addressLine>\n"
+ " <geoCodeGranularity>PROPERTY</geoCodeGranularity>\n"
+ " <latitude>-19.261365</latitude>\n"
+ " <longitude>146.815585</longitude>\n"
+ " <postcode>4810</postcode>\n"
+ " <state>QLD</state>\n"
+ " <suburb>Townsville</suburb>\n"
+ " <type>PHYSICAL</type>\n"
+ " </primaryAddress>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}