$re = '/^[a-zA-Z0-9].*\\\\$/';
$str = 'Root\\Panel\\pos1\\var572\\';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);