#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)nowrap=\"nowrap\" align=\"center.+?>(.+?)<\/td.+\n.+?align=\"right\"><a href=\"/.+?\/\">(.+?)<\/a>.+\n.+\n.+?href=\"\/teams\/.+?\">(.+?)<\/a>"
Local $sString = " <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">01:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/bayern-muenchen/">Bayern München</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/real-madrid/">Real Madrid</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" <a href="/report/freundschaft-vereine-2019-kalenderwoche-bayern-muenchen-real-madrid/" title="Match details Bayern München - Real Madrid">3:1 (1:0) </a>" & @CRLF & _
" </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">12:30</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/juventus/">Juventus</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/tottenham-hotspur/">Tottenham Hotspur</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" <img src="https://s.hs-data.com/bilder/shared/live/4.png">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">13:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/gillingham-fc/">Gillingham FC</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/millwall-fc/">Millwall FC</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" <img src="https://s.hs-data.com/bilder/shared/live/4.png">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">13:00</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/sv-lippstadt-08/">SV Lippstadt 08</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/ksv-baunatal/">KSV Baunatal</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">13:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/sportfreunde-lotte/">Sportfreunde Lotte</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/werder-bremen-ii/">Werder Bremen II</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">13:30</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/holstein-kiel/">Holstein Kiel</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/sheffield-wednesday/">Sheffield Wednesday</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" <a href="/report/freundschaft-vereine-2019-kalenderwoche-holstein-kiel-sheffield-wednesday/" title=" Holstein Kiel - Sheffield Wednesday">-:- </a>" & @CRLF & _
" </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">14:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/sc-verl/">SC Verl</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/arminia-bielefeld/">Arminia Bielefeld</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" <a href="/report/freundschaft-vereine-2019-kalenderwoche-sc-verl-arminia-bielefeld/" title=" SC Verl - Arminia Bielefeld">-:- </a>" & @CRLF & _
" </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">14:00</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/shrewsbury-town/">Shrewsbury Town</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/aston-villa/">Aston Villa</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" <img src="https://s.hs-data.com/bilder/shared/live/4.png">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">14:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/standard-liege/">Standard Liège</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/ogc-nice/">OGC Nice</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" <img src="https://s.hs-data.com/bilder/shared/live/4.png">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">14:00</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/sv-wehen-wiesbaden/">SV Wehen Wiesbaden</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/boavista/">Boavista</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">15:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/1-fsv-mainz-05/">1. FSV Mainz 05</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/jahn-regensburg/">Jahn Regensburg</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" <img src="https://s.hs-data.com/bilder/shared/live/4.png">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">15:00</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/rangers-fc/">Rangers FC</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/blackburn-rovers/">Blackburn Rovers</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" <img src="https://s.hs-data.com/bilder/shared/live/4.png">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">15:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/kvc-westerlo/">KVC Westerlo</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/krc-genk/">KRC Genk</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">16:00</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/atalanta/">Atalanta</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/ac-renate/">AC Renate</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="hell" nowrap="nowrap" align="center">16:00</td>" & @CRLF & _
" <td class="hell" align="right"><a href="/teams/lazio-roma/">Lazio Roma</a></td>" & @CRLF & _
" <td class="hell" align="center"> - </td>" & @CRLF & _
" <td class="hell"><a href="/teams/unione-triestina/">Unione Triestina</a></td>" & @CRLF & _
" <td class="hell" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="hell" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
" " & @CRLF & _
" <tr>" & @CRLF & _
" <td class="dunkel" nowrap="nowrap" align="center">16:00</td>" & @CRLF & _
" <td class="dunkel" align="right"><a href="/teams/spal-2013-ferrara/">SPAL 2013 Ferrara</a></td>" & @CRLF & _
" <td class="dunkel" align="center"> - </td>" & @CRLF & _
" <td class="dunkel"><a href="/teams/pordenone-calcio/">Pordenone Calcio</a></td>" & @CRLF & _
" <td class="dunkel" align="center" nowrap>" & @CRLF & _
" -:- </td>" & @CRLF & _
" <td class="dunkel" align="center">" & @CRLF & _
" </td>" & @CRLF & _
" </tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")