$re = '/^https?:\/\/www\.netapp\.com\/(\w{2})\/company\/leadership\/cloud-computing\/(index\.aspx)?$/';
$str = 'http://www.netapp.com/us/company/leadership/cloud-computing/index.aspx';
$subst = "http://www.netapp.com/\1/solutions/cloud/private-cloud/";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;