const regex = /(?<!a|
c(?=bobd)
)
bob(?!b)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!a|
c(?=bobd)
)
bob(?!b)', '')
const str = `abob cbobd `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}