use strict;
my $str = '0
::
1
::
+1
::
-1
::
1.e-1
::
1e1
::
.1e+1
::
-6*((2**(2+4))/3)
::
0*0
::
0+0
::
0/0
::
0^0
::
0**0
::
0-0
::
5 - -2
::
5- -2
::
5+-2
::
.1
::
1.
::
1.1
::
-2
::
5 * (2 + 5 /* comment */ // )
- 1)
INVALID: // Separated by :: to prevent parsing multiple examples
.
::
1e
::
1e+
::
1e-
::
e2
::
+
::
-
::
5 --2
';
my $regex = qr/# SETTINGS
(?<ANCHORED>){1}
(?<NO_SIGN_DUP>){1}
(?<PYTHON_POW>){1}
(?<COMMENTS>){0}
(?(ANCHORED)^(?&s)*)
(?(DEFINE)
(?<s>(?(COMMENTS)(?:\s+|\/\*[\s\S]*?\*\/|\/\/.*|\#.*)|\s+))
(?<sign>(?(NO_SIGN_DUP)(?<=(?<_>[\s\S]))(?!(?P=_)))[-+])
(?<base>\d+(?:\.\d*)?|\d*\.\d+)
(?<exp>(?:[eE][+-]?\d+))
(?<num>(?&sign)?(?&base)(?&exp)?(?!\w))
(?<bracketed>\((?&s)*(?&expr)(?&s)*\))
(?<atom>(?&num)|(?&bracketed))
(?<pow>(?&atom)(?:(?&s)*(?(PYTHON_POW)(?:\^|\*\*)|\^)(?&s)*(?&pow))*)
(?<mul>(?&pow)(?:(?&s)*[*\/](?&s)*(?&mul))*)
(?<add>(?&mul)(?:(?&s)*[+-](?&s)*(?&add))*)
(?<expr>(?&add))
)
(?&expr)
(?(ANCHORED)(?&s)*$)/xmp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}