import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(((0[1-9]|1[012])\\/(?!00|29)([012]\\d)|(0[13-9]|1[012])\\/(29|30)|(0[13578]|1[02])\\/31)\\/(18|19|20)\\d{2}|02\\/29\\/((18|19|20)(0[48]|[2468][048]|[13579][26])|2000))$";
final String string = "08/16/2005";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}