const regex = /^(\w+)\s+(\w+)\s([\w-:]+)\s+([\w-]+)\s+(?P<process>[\w-]+)(\[.*\]:|:)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\w+)\\s+(\\w+)\\s([\\w-:]+)\\s+([\\w-]+)\\s+(?P<process>[\\w-]+)(\\[.*\\]:|:)', '')
const str = `Sep 1 17:53:40 c7-ssm-01 journal: Rootkit Hunter: Please inspect this machine, because it may be infected.
Sep 1 17:53:40 c7-ssm-01 journal: Rootkit Hunter: Scanning took 1 minute and 31 seconds
Sep 1 17:52:09 c7-ssm-01 journal: Rootkit Hunter: Rootkit hunter check started (version 1.4.2)
Sep 1 17:49:26 c7-man-rds-01 journal: Rootkit Hunter: Please inspect this machine, because it may be infected.
Sep 1 17:49:26 c7-man-rds-01 journal: Rootkit Hunter: Scanning took 1 minute and 18 seconds
Sep 1 17:48:08 c7-man-rds-01 journal: Rootkit Hunter: Rootkit hunter check started (version 1.4.2)
Sep 1 17:24:17 c7-ids-01 journal: Rootkit Hunter: Please inspect this machine, because it may be infected.
Sep 1 17:24:17 c7-ids-01 journal: Rootkit Hunter: Scanning took 2 minutes and 6 seconds
Sep 1 17:22:11 c7-ids-01 journal: Rootkit Hunter: Rootkit hunter check started (version 1.4.2)
Sep 1 16:47:31 c7-dns-resolver-01 journal: Rootkit Hunter: Please inspect this machine, because it may be infected.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}