$re = '/<([^>\s]+)[^>]*>(?:\s*(?:br \/>| | | | | | | | )\s*)*<\/\1>/m';
$str = '<td><img width="100%" style="padding-bottom: 5px;" src="http://portalvhdsy6f8km33yt638.blob.core.windows.net/mediacontainer/20150827-GLC-header.gif" alt="" /></td><b > </b>
<br />
<b> </b>
<p></p>
<td><br /></td>
<td></td>
CLEARLY CONFUSED HERE:
<b><br /></b>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;