$re = '/.([0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\:[0-9]{1,5})/m';
$str = 'to:192.168.20.55:80
toasasas:192.168.20.55:80
addto:192.168.20.55:80adadd
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);