import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\\\n)|(\\\\r)|(\\\\t)|(\\u00A9)|([!\"#$%&()*+,-./:;<=>?@\\[\\\\\\]^_`\\{|\\}~])";
final String string = "Welcome to RegExr v2.0 by gskinner.com!\n\n"
+ "Edit the Expression & Text to see matches. Roll over matches or the expression for details. Undo mistakes with cmd-z. Save & Share expressions with friends or the Community. A full Reference & Help is available in the Library, or watch the video Tutorial.\n\n"
+ "Sample text for testing:\n"
+ "abcdefghijklmnopqrstuvwxyz ABCDEFGHIJKLMNOPQRSTUVWXYZ\n"
+ "0123456789 +-.,!@#$%^&*();\\/|<>'\"\"\n"
+ "12345 -98.7 3.141 .6180 9,000 +42\n"
+ "555.123.4567 +1-(800)-555-2468\n"
+ "foo@demo.net bar.ba@test.co.uk\n"
+ "www.demo.com http://foo.co.uk/\n"
+ "http://regexr.com/foo.html?q=bar\n\n"
+ "\"I'd 'give' A'rdor a TWO THUMBS UP!\\nLove the food. esp the Indian and total value for money!\\nThe drinks are well made and the food is to die for. \\nI've ubeen there about 5 times - mix of at night and for lunch.\\nDuring the night, its like the new watering hole for the young crowd, Love the energy it has. \\nThe ambiance is great.\\nFor those of you who have not been there yet, what are you waiting for?!\\n\\nI'll totally recommend this place to anyone!\"";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}