import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}\\._-]+@([A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}]{1,2}|[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}]((?<!(\\.\\.))[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}.-])+[A-Za-z0-9\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}])\\.[A-Za-z\\x{0430}-\\x{044F}\\x{0410}-\\x{042F}]{2,}$";
final String string = "дсацс@абсд.бг";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}