package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\(([0-9.]*)\)`)
var str = ` (0.5)
(1)
(24)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}