re = /(?:contact-us\/support-for-client-administrators\/glossary)(?:\/)?(?:.*[^0-9a-zA-Z].*)?(?:\\.aspx)?$/mi
str = 'https://banana.com/contact-us/support-for-client-administrators/glossary/affordable-care-act.aspx
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end