package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[\w\.-]+@[a-zA-Z\d\.-]+\.[a-zA-Z]{2,}$`)
var str = `test@g.cn`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}