$re = '/\s\/(?<serviceName>[^\/]*)/m';
$str = ' /gp-api-tierc-coupon/sxx/asdf/sdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);