import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/)?(v|player)\\.youku\\.com\\/(v_show|player\\.php|embed)(\\/.*sid)?\\/(id_)?(\\w+=*)|(\\w+)";
final String string = "http://v.youku.com/v_show/id_XMTMwMDYxMjQxMg==_ev_1.html?from=y1.3-idx-uhome-1519-20887.205805-205902.1-1\n"
+ "http://v.youku.com/v_show/id_XMjMxOTQyOTQw.html?from=y1.6-97.3.1.a44aa406e0c711df97c0\n"
+ "http://v.youku.com/v_show/id_XMTI5Mjg5NjE4MA==.html?from=y1.3-idx-uhome-1519-20887.205921-205922-205810-205923.1-1\n"
+ "http://v.youku.com/v_show/id_XMTI5Mjg5NjE4MA==.html\n"
+ "http://player.youku.com/player.php/sid/XMTI5Mjg5NjE4MA==/v.swf\n"
+ "http://player.youku.com/player.php/sid/XMTI5Mjg5NjE4MA==/v.swf\n"
+ "http://player.youku.com/embed/XMTI5Mjg5NjE4MA==\n"
+ "http://player.youku.com/player.php/Type/Folder/Fid/25924643/Ob/1/sid/XMTMwMDgxNTY0NA==/v.swf\n"
+ "http://player.youku.com/embed/XMTI5NTcwMDA3Mg==";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}