import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?i)(https?:\\/\\/)?(www\\.)?facebook\\.com\\/group(s)?(\\/?\\/\\d+)?(\\/.*)?$";
final String string = "Https://wWw.facebook.Com/GROUpS/2233223616820715\n"
+ "httpS://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223\n"
+ "https://www.facebook.com/groups/ukrainianenglishclubrachk21312Y\n"
+ "https://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd\n\n"
+ "Http://wWw.facebook.Com/GROUpS/hhGGGh/22332\n"
+ "http://Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223\n"
+ "httP://www.facebook.com/groups/ukrainianenglishclubrachk21312Y\n"
+ "http://www.facebook.com/groups/ukrainianenglishclubrachky/events/fd\n\n"
+ "wWw.facebook.Com/GROUpS/2233223616820715\n"
+ "Www.FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223\n"
+ "www.facebook.com/groups/ukrainianenglishclubrachk21312Y\n"
+ "www.facebook.com/groups/ukrainianenglishclubrachky/events/fd\n\n"
+ "facebook.Com/GROUpS/2233223616820715\n"
+ "FACEBOOk.cOm/grouP/2233223616820715/?hoisteD_section_header_type=recentLY_seen&multi_permalinks=2744661819010223\n"
+ "facebook.com/group/ukrainianenglishclubrachk21312Y\n"
+ "facebook.com/groups/ukrainianenglishclubrachky/events/fd\n\n"
+ "https://www.facebook.com/GROUPS/2233223616820715/?hoisted_section_header_type=recently_seen&multi_permalinks=2744661819010223\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}