$re = '/^(?:[a-zA-Z0-9\-\_]++\ *+(?(?=\,)\,+\ *+|$))*+$/m';
$str = 'test , testtest , testtest , test ,
test , test test , testtest , test ,
te_st , t0stt-st , te_sttest , test';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);