#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*斗地主"
Local $sString = "听好听的歌" & @CRLF & _
"" & @CRLF & _
"我想听蜻蜓fm郭德纲的相声" & @CRLF & _
"我要听蜻蜓fm郭德纲的相声等等等等" & @CRLF & _
"蜻蜓的是的是的" & @CRLF & _
"听周杰伦的歌" & @CRLF & _
"蜻蜓fm于谦的相声" & @CRLF & _
"蜻蜓fm的于谦的相声" & @CRLF & _
"想听skds的草根创业最好的项目" & @CRLF & _
"想听刘德华的歌" & @CRLF & _
"我想听于放的相声的地点的电视" & @CRLF & _
"想听好听的音乐" & @CRLF & _
"想听铁齿铜牙纪晓岚" & @CRLF & _
"我想听中国之声" & @CRLF & _
"要听圣诞节" & @CRLF & _
"" & @CRLF & _
"听蜻蜓fm" & @CRLF & _
"" & @CRLF & _
"我想听相声" & @CRLF & _
"好听的歌" & @CRLF & _
"听广播电台" & @CRLF & _
"周杰伦的菊花台" & @CRLF & _
"听fm" & @CRLF & _
"听六千的相" & @CRLF & _
"听加快时间打开手机端" & @CRLF & _
"听有声书" & @CRLF & _
"听音乐" & @CRLF & _
"听蜻蜓fm收银员" & @CRLF & _
"听歌曲" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")