const regex = /(?s)date_modified(?<date_modified>.*?)internal_id(?<internal_id>.*?)task(?<task>.*?)priority(?<priority>.*?)status(?<status>.*?)task_status(?<task_status>.*?)created(?<created>.*?)assigned(?<assigned>.*?)date_created(?<date_created>.*?)date_started(?<date_started>.*?)date_due(?<date_due>.*?)date_completed(?<date_completed>.*?)bunit(?<bunit>.*?)task_vendor(?<task_vendor>.*?)task_category(?<task_category>.*?)customer(?<customer>.*?)cust_name(?<cust_name>.*?)cust_territory(?<cust_territory>.*?)contact(?<contact>.*?)time_date(?<time_date>.*?)time_duration(?<time_duration>.*?)comment(?<comment>.*?)opportunity(?<opportunity>.*?)opp_status(?<opp_status>.*?)opp_engineer(?<opp_engineer>.*?)transaction(?<transaction>.*?)yeg_id(?<yeg_id>.*?)Recent Changes/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?s)date_modified(?<date_modified>.*?)internal_id(?<internal_id>.*?)task(?<task>.*?)priority(?<priority>.*?)status(?<status>.*?)task_status(?<task_status>.*?)created(?<created>.*?)assigned(?<assigned>.*?)date_created(?<date_created>.*?)date_started(?<date_started>.*?)date_due(?<date_due>.*?)date_completed(?<date_completed>.*?)bunit(?<bunit>.*?)task_vendor(?<task_vendor>.*?)task_category(?<task_category>.*?)customer(?<customer>.*?)cust_name(?<cust_name>.*?)cust_territory(?<cust_territory>.*?)contact(?<contact>.*?)time_date(?<time_date>.*?)time_duration(?<time_duration>.*?)comment(?<comment>.*?)opportunity(?<opportunity>.*?)opp_status(?<opp_status>.*?)opp_engineer(?<opp_engineer>.*?)transaction(?<transaction>.*?)yeg_id(?<yeg_id>.*?)Recent Changes', 'gm')
const str = `date_modified21-DECEMBER-2020 12:25 PMinternal_id313017task2nd Year Annual
billing pricing -34515priorityMediumstatusCompletedtask_statusAllocatedcreated
Bernadine PereraassignedBernadine Pereradate_created21-DECEMBER-2020 12:25 PM
date_started21-DECEMBER-2020date_due21-DECEMBER-2020date_completed
21-DECEMBER-2020bunitOperationstask_vendorSplunktask_categoryOthercustomer
cust_namecust_territorycontacttime_datetime_durationcommentopportunityopp_status
opp_engineertransaction yeg_idRecent Changes
DateSet byContextTypeFieldOld ValueNew Value21-DECEMBER-2020 12:25 PMBernadine
PereraUISetStart Date21-DECEMBER-2020 12:00 Utc21-DECEMBER-2020 12:25 PM
Bernadine PereraUISetOwnerBernadine Perera21-DECEMBER-2020 12:25 PMBernadine
PereraUISetAssignedBernadine Perera21-DECEMBER-2020 12:25 PMBernadine PereraUI
SetBusiness UnitOperations21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask
CategoryOther21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask StateAllocated
21-DECEMBER-2020 12:25 PMBernadine PereraUISetTask VendorSplunk21-DECEMBER-2020
12:25 PMBernadine PereraUICreateRecordTASK313017You requested to receive an
email alert for this record. Click here to modify your email alerts
[https://55349.app.netsuite.com/app/center/userprefs.nl?sc=-29&selectedtab=alerts]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}