# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?i)(?=(\d)\d\d([\s\-\x{2013}\x{2014}\/]))(?<![\d\-\x{2013}\x{2014}%])(?!000|666|9\d\d|\1{3}.\1{2}.\1{4}?|012.34.5678|123.45.6789|234.56.7890|098.76.5432|876.54.3210|078.05.1120|219.09.9999)\d{3}\2(?!00)\d{2}\2(?!0000)\d{4}(?![\d\-\x{2013}\x{2014}%])(?!\.(?:pdf|docx?|xlsx?|pptx?|zip|jpe?g|png|txt|log)\b)"
test_str = ("################\n"
"## Must match:\n"
"################\n\n"
"123-45-4891\n"
"098-18-6564\n"
"123-45-4848\n"
"702-02-0202\n"
"001-14-0004\n\n"
"009 95 8881\n"
"123-45-4891 is my ssn\n"
"my ssn is 123-45-4891\n"
"my ssn is 123-45-4891 ok?\n"
"my ssn is 123-45-4891.\n"
"123454891 is my ssn\n\n"
"123 45 4891 is my ssn\n"
"my ssn is 123 45 4891\n"
"my ssn is 123 45 4891 ok?\n"
"my ssn is 123 45 4891.\n"
"my ssn is:123-45-4891.\n"
"my ssn is:123 45 4891.\n"
"my ssn is:123454891.\n"
"ss#123-45-4891\n"
"ssn123-45-4891\n\n"
"# Space separator:\n"
"123 45 4891\n\n"
"# Emdash separator:\n"
"123–45–4891\n\n"
"# Endash separator:\n"
"123—45—4891\n\n"
"# Slash separator\n"
"123/45/4891\n\n"
"################\n"
"## Must not match:\n"
"################\n\n"
"# Unformatted SSN:\n"
"009958881\n"
"my ssn is 123454891\n"
"my ssn is 123454891 ok?\n"
"my ssn is 123454891.\n\n"
"# All-Zero sequence\n"
"231-84-0000\n"
"231-00-7289\n"
"000-87-7289\n"
"231 84 0000\n"
"231 00 7289\n"
"000 87 7289\n\n"
"# Starting with 9\n"
"908-78-0485\n"
"908 78 0485\n\n"
"# Starting with 666\n"
"666-78-0485\n\n"
"# Same number sequences:\n"
"222-22-2222\n"
"555-55-5555\n\n"
"# Ascending/Descending sequences:\n"
"123-45-6789\n"
"876-54-321\n\n"
"# Known invalidated SSN:\n"
"219-09-9999\n"
"078-05-1120\n\n"
"# File names with common extensions:\n"
"123-45-4891.pdf\n"
"123-45-4891.xlsx\n"
"Check the attachment: 123-45-4891.xls, then get back to me.\n"
"Check the attachment: 123-45-4891.jpeg, then get back to me.\n\n"
"# Extra digits:\n"
"1123-45-4891\n"
"123-45-48911\n\n"
"# Unsupported boundaries:\n"
"–123-45-4891\n"
"—123-45-4891\n"
"%123-45-4891\n"
"123-45-4891-\n"
"123-45-4891—\n"
"123-45-4891%\n"
"1-123-45-4891\n"
"123-45-4891-1\n\n"
"# Telephone\n"
"1-234-567-8901\n"
"1-234-567-8901\n"
"1-234-567-8901 \n"
"1 (234) 567-8901\n"
"12347658901\n\n"
"# Credit card \n"
"5500 0000 0000 0004\n"
"3400 0000 0000 009\n"
"3000 0000 0000 04\n"
"5500-1244-2232-0004\n"
"3400-1244-0000-009\n"
"3000-1244-1234-04\n\n"
"# Random Numbers\n"
"1234567890112371298739872891738912738937289d712897381297381927d3128937893d7218947d1892742189duc89789v127c897412987893c12893c79\n"
"122-426-389\n"
"187-5-43212\n"
"187-0-43212\n"
"2423-45-6789\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.