re = /(([a-fA-F0-9]{8})-([a-fA-F0-9]{4})-([a-fA-F0-9]{4})-([a-fA-F0-9]{4})-([a-fA-F0-9]{12}))/m
str = '1d95e013-3c09-4883-88f1-4337ba0b8ddc'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end