re = /^(?:\s+)(applicationId\s)(?:\")(\S+)(?:\")/
str = ' applicationId "com.getflamingo"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end