#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(DEFI?)*\s?[A-Z]([A-Z]|[0-9]){0,4}=(([A-Z]([A-Z]|[0-9]){0,4})|([0-9]+(\.[0-9]+)?))\s?(DEFI?)*$"
Local $sString = "S=20845.2518 DEFI"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")