const regex = /^[^#]{2,32}#\d{3}[1-9]|(?!.*\.\.)[a-z\d_.]{2,32}€/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^#]{2,32}#\\d{3}[1-9]|(?!.*\\.\\.)[a-z\\d_.]{2,32}€', 'gm')
const str = `Sten#0001`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}