// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?)\AX{2}-X{6}\z|\A(C?((0[1-9])|(1[0-2])))-[0-4][0-9A-Z]{4}[14]\z").unwrap();
let string = "XX-XXXXXX";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}