#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=<.+.>)(.*?)(?=<.*\/.+.?>)"
Local $sString = "<h1>HTML Ipsum Presents</h1>" & @CRLF & _
"" & @CRLF & _
"<p><strong>Pellentesque habitant morbi tristique</strong> senectus et netus et malesuada fames ac turpis egestas. Vestibulum tortor quam, feugiat vitae, ultricies eget, tempor sit amet, ante. Donec eu libero sit amet quam egestas semper. <em>Aenean ultricies mi vitae est.</em> Mauris placerat eleifend leo. Quisque sit amet est et sapien ullamcorper pharetra. Vestibulum erat wisi, condimentum sed, <code>commodo vitae</code>, ornare sit amet, wisi. Aenean fermentum, elit eget tincidunt condimentum, eros ipsum rutrum orci, sagittis tempus lacus enim ac dui. <a href="#">Donec non enim</a> in turpis pulvinar facilisis. Ut felis.</p>" & @CRLF & _
"" & @CRLF & _
"<h2>Header Level 2</h2>" & @CRLF & _
"" & @CRLF & _
"<ol>" & @CRLF & _
" <li>Lorem ipsum dolor sit amet, consectetuer adipiscing elit.</li>" & @CRLF & _
" <li>Aliquam tincidunt mauris eu risus.</li>" & @CRLF & _
"</ol>" & @CRLF & _
"" & @CRLF & _
"<blockquote><p>Lorem ipsum dolor sit amet, consectetur adipiscing elit. Vivamus magna. Cras in mi at felis aliquet congue. Ut a est eget ligula molestie gravida. Curabitur massa. Donec eleifend, libero at sagittis mollis, tellus est malesuada tellus, at luctus turpis elit sit amet quam. Vivamus pretium ornare est.</p></blockquote>" & @CRLF & _
"" & @CRLF & _
"<h3>Header Level 3</h3>" & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
" <li>Lorem ipsum dolor sit amet, consectetuer adipiscing elit.</li>" & @CRLF & _
" <li>Aliquam tincidunt mauris eu risus.</li>" & @CRLF & _
"</ul>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")