import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",([^,]*)$";
final String string = "http://stackoverflow.com/questions/3829483/how-to-replace-last-occurrence-of-characters-in-a-string-using-javascript\n"
+ "DailyStats,jlaidler;priya.patil;twagg;cwood;dgalt;lmckerrow;sunaina.goswami;mfreidgeim;aorlov;ngunasekera;jviegas;nanderson;csutianto;mfagan;hkerruish;sbeasley;vshah;dsretenovic;llewis;tearl;dsretenovich;emcnamara;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,DailyStatsAdm\n"
+ "AuditEvents,aorlov;priya.patil;ngunasekera;sunaina.goswami;mfreidgeim;jchicas;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,AuditEventsAdm\n"
+ "AuditBookings,sunaina.goswami;priya.patil;mfreidgeim;aorlov;ngunasekera;vshah;llewis;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,AuditBookingsAdm\n"
+ "TrendAnalysis,jlaidler;priya.patil;sunaina.goswami;mfreidgeim;aorlov;ngunasekera;jviegas;nanderson;csutiantoa;awinter;sbeasley;tearl;sunaina.goswami;dsretenovich;cdignan;asridhar;PWade;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,TrendAnalysisAdm\n"
+ "MemberAnalysis,sunaina.goswami;priya.patil;mfreidgeim;aorlov;ngunasekera;rkapoor;mfagan;sbeasley;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,MemberAnalysisAdm\n"
+ "WebMatch,priya.patil;priya.patil;dgalt;lmckerrow;mfreidgeim;aorlov;ngunasekera;mfagan;lbrown;asmart;chirt;abishop;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,WebMatchAdm\n"
+ "MDFData,lmckerrow;mfreidgeim;priya.patil;aorlov;ngunasekera;GSattler;vshah;llewis;tearl;sunaina.goswami;dsretenovich;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,MDFDataAdm\n"
+ "MDFReport,jlaidler;lmckerrow;priya.patil;mfreidgeim;aorlov;ngunasekera;tearl;sunaina.goswami;dsretenovich;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,MDFReportAdm\n"
+ "PackagesAdmin,XXXX;priya.patil;jkhan;abell;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,PackagesAdminAdm\n"
+ "FaresManager,mfreidgeim;priya.patil;aorlov;ngunasekera;GSattler;lbrown;asmart;ndias;dgalt;dbuckley;jchicas;vshah;llewis;abell;tearl;sunaina.goswami;dsretenovich;hkerruish;emcnamara;Pete.Donovan;Lynsey.Walker;asridhar;jkhan;gilbert.teo.ctr;tearle;mtran;nkhanna;huiwan_chua;tzeyuan.chan.ctr;sookfun.how.ctr;yvonne.du;desmond.phua;huiping.tan;sipkhoon.tan;alice.yeo.ctr;chris.mak;danny.cheung;Trisa.yau;Michelle.ng.ctr;lmckerrow;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FaresManagerAdm\n"
+ "RNGenerator,dgalt;priya.patil;mfreidgeim;aorlov;ngunasekera;mfagan;chirt;abishop;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,RNGeneratorAdm\n"
+ "PBEManager,dgalt;priya.patil;lmckerrow;mfreidgeim;aorlov;ngunasekera;bgeorge;vshah;llewis;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,PBEManagerAdm\n"
+ "InsuranceManager,lmckerrow;priya.patil;mfreidgeim;aorlov;ngunasekera;csutianto;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,InsuranceManagerAdm\n"
+ "FiltersManager,mfreidgeim;priya.patil;aorlov;ngunasekera;GSattler;twagg;sunaina.goswami;tearle;dbuckley;vshah;dsretenovic;abell;llewis;hkerruish;emcnamara;Pete.Donovan;Lynsey.Walker;asridhar;jkhan;gilbert.teo.ctr;lmckerrow;mtran;nkhanna;tzeyuan.chan.ctr;gilbert.teo.ctr;sookfun.how.ctr;chris.mak;danny.cheung;Trisa.yau;Michelle.ng.ctr;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FiltersManagerAdm\n"
+ "CarHireCMS,lmckerrow;priya.patil;mfreidgeim;aorlov;ngunasekera;cwood;csutianto;sunaina.goswami;dsretenovic;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,CarHireCMSAdm\n"
+ "HSAAdministration,lmckerrow;priya.patil;mfreidgeim;aorlov;ngunasekera;csutianto;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,HSAAdministrationAdm\n"
+ "FareEscalationJournal,mfreidgeim;priya.patil;aorlov;ngunasekera;pwade;acaneda;lutupo;vlama;nensor;jviegas;nanderson;rkapoor;achopra;twagg;cwood;csutianto;ltrain;sunaina.goswami;vshah;dsretenovic;llewis;mpeguero;abishop;epinchen;tcornish;mten;asridhar;jkhan;abell;tearle;mtran;iarumairaj;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FareEscalationJournalAdm\n"
+ "FareEscalationPaymentTypeReport,aorlov;priya.patil;ngunasekera;mfreidgeim;pwade;acaneda;lutupo;vlama;nensor;jviegas;nanderson;rkapoor;vshah;llewis;mpeguero;abishop;epinchen;tearl;sunaina.goswami;dsretenovich;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FareEscalationPaymentTypeReportAdm\n"
+ "FareEscalationAuthorisation,mfreidgeim;priya.patil;aorlov;ngunasekera;jviegas;nanderson;rkapoor;rmalik;amohammed;sfuimaono;sskinner;mburrows;cwood;kspreckley;jquinn;mspalding;taugustin;twagg;sstark;amohammed;GRoos;amcmeeken;adutta;mrawat;sunaina.goswami;vshah;dsretenovic;llewis;sdriver;asridhar;lserapiglia;tearle;mtran;slinssen;sdriver;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FareEscalationAuthorisationAdm\n"
+ "FareEscalationReport,mfreidgeim;aorlov;priya.patil;ngunasekera;twagg;pwade;lutupo;vlama;jviegas;nanderson;lmckerrow;rkapoor;csutianto;cwood;sunaina.goswami;vshah;dsretenovic;llewis;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FareEscalationReportAdm\n"
+ "FareEscalationFinanceAMEXReport,aorlov;priya.patil;ngunasekera;mfreidgeim;pwade;acaneda;lutupo;vlama;nensor;jviegas;nanderson;rkapoor;vshah;llewis;mpeguero;abishop;epinchen;tearl;sunaina.goswami;dsretenovich;asridhar;jkhan;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FareEscalationFinanceAMEXReportAdm\n"
+ "FareEscalationManagers,mfreidgeim;aorlov;priya.patil;ngunasekera;cwood;mspalding;jquinn;taugustin;mburrows;twagg;sskinner;GRoos;sfuimaono;sstark;amohammed;amcmeeken;sunaina.goswami;dsretenovic;tearl;sdriver;asridhar;lserapiglia;tearle;mtran;slinssen;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,FareEscalationManagersAdm\n"
+ "MultiplePCC,mfreidgeim;aorlov;ngunasekera;priya.patil;tearle;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,MultiplePCCAdm\n"
+ "CampaignManager,priya.patil;aorlov;priya.patil;ngunasekera;mfreidgeim;msugatadasa;aorlov;ngunasekera;ndias;jchicas;vshah;llewis;skaul;tearl;sunaina.goswami;dsretenovich;skaul;pfountas;lmckerrow;drossa;jgarton;jchicas;dbuckley;jkhan;jchokka;nwhite;gilbert.teo.ctr;tzeyuan.chan.ctr;sookfun.how.ctr;huiwan.chua.ctr;abell;nkhanna;Pete.Donovan;mjaneo;bhong;jonathan.guido,CampaignManagerAdm\n"
+ "InterlineManager,mfreidgeim;priya.patil;aorlov;ngunasekera;tearl;sunaina.goswami;dsretenovich;asridhar;tearle;mtran;jkhan;abell;Pete.Donovan;dbuckley;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,InterlineManagerAdm\n"
+ "DynamicPackaging,XXXX,DynamicPackagingAdm\n"
+ "HotelFiltersManager,cwood;priya.patil;mfreidgeim;aorlov;ngunasekera;twagg;sunaina.goswami;tearle;dbuckley;dsretenovic;abell;hkerruish;emcnamara;Pete.Donovan;Lynsey.Walker;asridhar;jkhan;gilbert.teo.ctr;lmckerrow;mtran;chris.mak;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,HotelFiltersManagerAdm\n"
+ "ChangeUserStatus,cwood;kspreckley;priya.patil;mspalding;mfreidgeim;aorlov;ngunasekera;tearle;sunaina.goswami;dsretenovic;asridhar;mtran;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,ChangeUserStatusAdm\n"
+ "BargainBotCampaignEditor,mfreidgeim;priya.patil;jchicas;jchicas;tearl;sunaina.goswami;dsretenovich;asridhar;pfountas;gilbert.teo.ctr;tearle;mtran;nkhanna;huiwan_chua;tzeyuan.chan.ctr;sookfun.how.ctr;yvonne.du;desmond.phua;huiping.tan;sipkhoon.tan;alice.yeo.ctr;chris.mak;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,BargainBotCampaignEditorAdm\n"
+ "BargainBotCampaignManager,mfreidgeim;priya.patil;lmckerrow;aorlov;ngunasekera;jchicas;tearl;sunaina.goswami;dsretenovich;Pete.Donovan;Lynsey.Walker;asridhar;pfountas;gilbert.teo.ctr;tearle;mtran;nkhanna;huiwan_chua;tzeyuan.chan.ctr;sookfun.how.ctr;yvonne.du;desmond.phua;huiping.tan;sipkhoon.tan;alice.yeo.ctr;chris.mak;danny.cheung;Trisa.yau;Michelle.ng.ctr;Chris.Mak;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,BargainBotCampaignManagerAdm\n\n"
+ "LogonAsMember,aorlov;ngunasekera;mfreidgeim;priya.patil;dgult;komahony;kscott;lbrown;mfagan;amohammed;amcmeeken;achopra;ACaneda;csutianto;CWood;dphilalay;elee;gsattler;groos;jkhan;jcoulter;jquinn;LStevanovic;mspalding;mmcintyre;MSheil;medwards;mbrown;nensor;syearwood;sstark;taugustin;twagg;tmcavaney;vjulka;zkemp;aanand;asiani;adutta;bdhawan;dverma;jsharma;knarang;ktiwari;kgarg;kraj;mchandra;mrawat;mrana;msingh;nnagpal;pselvaraj;prawat;rbisht;rsood;sjaved;schauhan;sandeepkumar;smalik;ssingh;vrawat;abaldores;aportes;avictorio;apedrola;bmay;cyan;cpachoco;dregalado;daranas;ecuaresma;ebarinque;egonzalez;fmarana;gcarino;ialbiso;jmartinez;jsarong;jlee;jbiron;jmeija;jragasa;jguayco;jvelasco;jreyes;lsanchez;mdonato;mravelas;mabraham;mcruz;mbaun;mquiobo;mjacob;mgonzalo;psijera;rsampigan;rcortes;rofiaza;squebral;sramos;uvirgilio;victor.sales;mcerrada;sunaina.goswami;tearle;ndias;msugatadasa;akshay.santosh;nwhite;lmckerrow;jchicas;akabir;sbeasley;vshah;dsretenovic;abell;llewis;mpeguero;abishop;epinchen;tcornish;sdriver;asridhar;mtran;jkhan;pfountas;gilbert.teo.ctr;tearle;huiwan_chua;tzeyuan.chan.ctr;sookfun.how.ctr;yvonne.du;chris.mak;danny.cheung;Trisa.yau;Michelle.ng.ctr;slinssen;sdriver;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,LogonAsMemberAdm\n"
+ "CreditCardCheck,aorlov;ngunasekera;mfreidgeim;priya.patil;sunaina.goswami;tearle;vshah;dsretenovic;llewis;tearl;sunaina.goswami;asridhar;tearle;mtran;slinssen;sdriver;jonathan.guido,CreditCardCheckAdm\n"
+ "PendingApplications,aorlov;ngunasekera;mfreidgeim;priya.patil;duckley;amohammed;amcmeeken;achopra;ACaneda;csutianto;CWood;dphilalay;elee;gsattler;groos;jkhan;jcoulter;jquinn;LStevanovic;mspalding;mmcintyre;MSheil;medwards;mbrown;nensor;syearwood;sstark;taugustin;twagg;tmcavaney;vjulka;zkemp;aanand;asiani;adutta;bdhawan;dverma;jsharma;knarang;ktiwari;kgarg;kraj;mchandra;mrawat;mrana;msingh;nnagpal;pselvaraj;prawat;rbisht;rsood;sjaved;schauhan;sandeepkumar;smalik;ssingh;vrawat;abaldores;aportes;avictorio;apedrola;bmay;cyan;cpachoco;dregalado;daranas;ecuaresma;ebarinque;egonzalez;fmarana;gcarino;ialbiso;jmartinez;jsarong;jlee;jbiron;jmeija;jragasa;jguayco;jvelasco;jreyes;lsanchez;mdonato;mravelas;mabraham;mcruz;mbaun;mquiobo;mjacob;mgonzalo;psijera;rsampigan;rcortes;rofiaza;squebral;sramos;uvirgilio;victor.sales;mcerrada;vlama;ltrain;nanderson;awinter;pwade;sunaina.goswami;tearle;msugatadasa;akshay.santosh;nwhite;ndias;lmckerrow;jchicas;akabir;cmcalpine;sbeasley;elangen;vshah;dsretenovic;abell;llewis;mpeguero;abishop;epinchen;tcornish;sdriver;cdignan;retiennette;Amir.Marzouk;Belinda.Pignone;Charmaine.lee;Glenn.tan;Ivy.kee;Joanne.gatus;Katie.Malone;Lawrence.quek.ct;Lynsey.Walker;Maricon.balmes;Melissa.Scully;Merlin.mathew;Millicent.Myers;Nur.faiza.ctr;Paul.Seaman;Pete.Donovan;Phekpin.phuah.ctr;Umair.Riaz;asridhar;jkhan;mtran;lserapiglia;pfountas;gilbert.teo.ctr;tearle;huiwan_chua;tzeyuan.chan.ctr;sookfun.how.ctr;yvonne.du;chris.mak;danny.cheung;Trisa.yau;Michelle.ng.ctr;iarumairaj;slinssen;sdriver;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,PendingApplicationsAdm\n"
+ "MobileSupport,aorlov;ngunasekera;mfreidgeim;priya.patil;sunaina.goswami;tearle;msugatadasa;akshay.santosh;nwhite;lmckerrow;jchicas;akabir;amohammed;amcmeeken;CWood;dphilalay;;gsattler;groos;jkhan;jquinn;mspalding;sstark;taugustin;twagg;vjulka;zkemp;;abaldores;aportes;avictorio;apedrola;bmay;cyan;cpachoco;dregalado;daranas;ecuaresma;ebarinque;egonzalez;fmarana;gcarino;ialbiso;jmartinez;jsarong;jlee;jbiron;jmeija;jragasa;jguayco;jvelasco;jreyes;lsanchez;mdonato;mravelas;mabraham;mcruz;mbaun;mquiobo;mjacob;mgonzalo;psijera;rsampigan;rcortes;rofiaza;squebral;sramos;uvirgilio;victor.sales;mcerrada;akabir;cmcalpine;elangen;vshah;dsretenovic;llewis;sdriver;asridhar;tearle;mtran;slinssen;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,MobileSupportAdm\n"
+ "ProviderStatusManagementAccess,aorlov;priya.patil;ngunasekera;mfreidgeim;sunaina.goswami;tearle;msugatadasa;akshay.santosh;nwhite;lmckerrow;jchicas;akuruwita;ndias;asridhar;tearle;mtran;chris.mak;danny.cheung;Trisa.yau;Michelle.ng.ctr;jchokka;vinh.ngo;msugatadasa;akshay.santosh;nwhite;jonathan.guido,ProviderStatusManagementAccess";
final String subst = ";$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}