const regex = /\[([^\[\]]++|(?R))*+\]/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[([^\\[\\]]++|(?R))*+\\]', '')
const str = `<p>A body of text with a media module element embedded.<p>[[{"fid":"1234","view_mode":"full","type":"media","attributes":{"height":281,"width":224,"style":"float: right;","alt":"image caption","title":"Image name","class":"media-element file-full"}}]]<p>Proin faucibus ullamcorper sapien. In viverra faucibus imperdiet. Proin a libero vulputate, imperdiet turpis eu, congue arcu. Quisque id nullam.</p>
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}