const regex = /(^[2-9][0-9]{2}$)|(^[1-2][0-9]{3}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^[2-9][0-9]{2}$)|(^[1-2][0-9]{3}$)', 'gm')
const str = `1
12
19
20
21
29
30
31
40
50
60
70
80
98
99
100
101
102
149
150
180
190
199
200
201
202
300
400
500
600
999
1000
1001
1002
2000
3000
9999
10000
10001
10002
10003
19999
20000
20001
20002
30000
50000
60000
99999
100000
100001
30000000
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}